Jump to content
bella42

Matrix Coding Query of nodes - no results

Recommended Posts

Hi all,

 

I've struggled to develop a query which seems like it would be straightforward, but it never generates any results. I am trying to do a matrix coding query of one group of hierarchical nodes against another group of hierarchical nodes. The two groups of nodes look like this in the hierarchy:

 

Cohesion

- single viewpoint

- multiple viewpoints

 

Difference

- accentuating

- bracketing

- normalizing

- resolving

 

I select my nodes in the desired rows and columns, using the default "AND" operator, and the query returns no results. I am selecting nodes which have data in all which should generate results, so I'm stumped. In other words, I know that (minimally) at least one individual source has been coded in each of these rows and columns, and hence should return the results.

 

I have successfully set up a matrix coding query of nodes against source attributes with no issues. Thinking it might be an issue of it not liking node to node matrix queries (which just seems odd), I gave all of these nodes node attributes and tried the query using that, still with no results. While I was doing this, I tried a node (column) to node attribute (row) query and a node attribute (row) query to another node attribute (column) query.

 

I'm completely stumped and thinking I am missing something obvious. Any advice?

 

Thanks in advance for any help you can give. I know the data are in there, I just want to see them easily! :)

 

-Allison

Share this post


Link to post
Share on other sites

Hi Allison,

 

Thank you for your forum post.

 

When you selected your node from the 'Select Project Items' dialogue box, please ensure you have checked the 'Automatically select descendant nodes' box.

This box is located on top-centre part of the dialogue box and it is not ticked by default. If this is not checked, all child nodes do not get selected even if you tick the parent node.

 

The other common mistake I have seen is selecting a node with no coding inside, but I believe this is not the case with you.

 

If the box is ticked and you are still experiencing the same issue, please submit a contact support form attaching your project file and we can provide further assistance.

 

I hope this helps.

 

Jun

Share this post


Link to post
Share on other sites

Hi

 

I have exactly the same problem and have followed the suggestions in the above reply, but they haven't worked. Please help.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi susieh,

 

A Matrix Coding query looks at two project items and checks if they both occur at the same place.

You will need to ensure that the query you are running has references in both nodes you are querying.

For more information on Matrix Coding queries, please see our help file:

http://help-nv10.qsrinternational.com/desktop/procedures/run_a_matrix_coding_query.htm

 

I hope this helps,

Andrew

Share this post


Link to post
Share on other sites

Hi

 

I also have this issue although I am trying to run a crosstab of two node classifications (gender x age). The values are selected. The query is returned saying "no results" but I have set up my cases as nodes and imported the classification sheet - everything looks OK.

 

Could someone please advise? I used to do this in earlier versions using base data nodes/casebook but am trying to use classifications this time.

 

Best Wishes
Emma

Share this post


Link to post
Share on other sites

EMU_C ISSUE SOLVED.

 

Update to anyone who also encounters this issue. When importing the node classification sheet, in step 3, make sure to click on "as Names" and then specify your subfolder (eg Case Nodes). I was using "as hierarchical names". This will then retrieve results in a matrix query.

Share this post


Link to post
Share on other sites

Hi all,

 

I have a similar problem: I am trying to test the associations in between different nodes (project items) via a coding query using the "AND" operator but always end up with "no results". I did everything according to the advice given in this thread (checked that nodes actually contain coding, checked the 'Automatically select descendant node´ and clicked on "as Names" and specified the subfolder (eg Case Nodes) when importing the node classification sheet).

 

Please help!!

 

Many thanks in advance,

Christine

 

 

Share this post


Link to post
Share on other sites

Hi Christine,

 

It's a bit difficult to know what is going wrong without more information. Perhaps you could copy your query criteria into a post and describe what you think you are searching for?

 

Assuming (from your message) that you are looking for intersecting content between two nodes, for cases assigned to a particular attribute value, your coding query criteria should look something like this:

 

Content Coded at all of these nodes: {Node A, Node B}

AND Coded at any node where Person:Gender = Female

 

This query would return any content from my female cases that is coded at both Node A and Node B.

 

(Note: If I have a Female case and I have coded one paragraph to Node A and a separate paragraph to node B, I would not get any result for that case. The coded content must overlap, and only that part that is overlapping will be returned in the query results.)

 

Thanks,

Kate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×