Jump to content

Recommended Posts

Hi all,

 

I have revived an old thread in Nvivo9/10 forum about query timeout.

 

I have gratefully received a response from QSR helpdesk about this topic and so am sharing this in case anyone else finds it useful:

 

Firstly, please follow the steps below to perform a Compact and Repair of your project:

1. If your project is located on a network drive, copy it to your local machine.

2. If the project is currently open, close the project via File > Close.

3. Click the File tab > Help > Compact and Repair Project.

4. At the Select Project dialog box, locate and select the project - select NVivo Projects (*.nvp) to repair a standalone project.

5. Click Open.

If the issue persists, you may need to change the SQL Time out period manually by editing your configuration file. This may be a little technical. You can ask your IT support personnel to help you with this if you are unable to do this yourself. The steps are below:

o Ensure NVivo 11 is closed.

o Go to Start -> All Programs -> Accessories -> Wordpad

o Click on File -> Open. Ensure "All Documents (*.*) is selected in the 'Files of Type' dropdown menu in the Open dialog box.

 

1. With NVivo 11 closed, open Windows Explorer

a) Right-click on the Windows Start circle -> Explore.

2. Display all hidden files and folders:

a) Click on Organize -> Folder and Search Options

B) On the 'Folder Options' dialog, click on the View tab and check 'Show hidden files and folders' option

c) Click on the Apply button and click OK.

2. Navigate to the following folders:

C:\Users\[username]\AppData\Roaming\QSR_International1

o You should see few folders that start with NVivo.exe..... Go into the first folder and see if it has subfolder named "11.1.0.411"2. If not, go back one level and go into the second NVivo.exe.. folder to see if it has a 11.1.0.4112 subfolder One of the two folders will definitely have a subfolder named "11.1.0.411"2. Go into this subfolder (11.1.0.411)2. You should see a file called user.config, double click on it to open it.(Open it with Notepad)

o The 19th3 line from top in this file (or one or two lines above or below) should have something that says SqlCommandTimeout setting. The next line should have a value of 60. Change this value to a higher number like 120 or 180.

o Open NVivo 11 and re-run your query. If you still get the same error. Try increasing the timeout value to a higher number.

Please note changing the sqltimeout value may result in the Cancel button (when you run a query) to become unresponsive.

Lastly, if you are using 32-bit NVivo 11, it will also help to switch to 64-bit version. Please refer to the link below to find whether you can install 64-bit,

http://www.qsrinternational.com/support_faqs_detail.aspx?view=1189

 

1. Rather than going through all those steps, I found it easier to type %appdata% into my Windows Explorer and choose the right version of Nvivo from there.

2. Just to point out that this number is the version of Nvivo you're running. Your version may be different, so check this first. You can do that by going to 'File', 'Help', 'About Nvivo'.

3. It was not the 19th line for me. I just used CTRL+F to find the SqlCommandTimeout setting.

  • Like 3

Share this post


Link to post
Share on other sites

Thanks for posting this! I ran into the same issue.

I am finding that the config file seems to override the edits you indicated above and resets back to 60 seconds when I restart the program. I'm on a military network and am wondering if its because I am attempting to make changes as an non-admin user, or if its for another reason.

I'm surprised there is now way to change the command timeout in the GUI.

Share this post


Link to post
Share on other sites

Please disregard my response it looks like I was saving in the .bak file which I learned from our IT guy is a backup file and is not the file that changes the configuration. It works now and my analysis went off without any issue :).

Share this post


Link to post
Share on other sites

I'm having a problem with matrix queries timing out, but it seems to be a different sort of problem. I can run matrix queries that have just a couple attributes on one axis and nodes on the other axis within a reasonable time. But any matrix that has 1) attributes on both axes (even if just a few), as well as any matrix that has 2) a lot of attributes on one axis and nodes on another, takes an exceedingly long time (over five minutes) or times out. I already compacted and repaired the database and there was no noticeable change. It seemed like queries ran faster yesterday than today, but on further investigation I think it has to do with the two specific query design characteristics listed above. I tried running queries on earlier, backed up versions of the project and it was the same. My project is only 25MB with less than 1,000 references. I could reset the timeout period, but this doesn't seem to be the underlying problem.

Suggestions, please? We are trying to wrap up the final stages of analysis, so this is very bad timing. Thanks.

Share this post


Link to post
Share on other sites

Update: I was able to do a work-around in one case by converting a two-dimension attribute to two nodes, and applying each of the codes to entire transcripts, as applicable. I used the same query structure, and simply replaced the two attribute values with the two codes. It processed within a matter of seconds. However, it makes no sense to have to treat attributes as nodes simply to cross-tabulate attribute data with other data. I'd still be interested to hear any recommendations for excessively slow matrix queries involving attributes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×