Jump to content

How to ignore "you know" in searches


Recommended Posts

How can I add "you know" to the list of stop words, seeing as it's actually two words? I'd like to analyse the word "know" in my interview transcripts but to ignore this phrase in the results.

Hope someone can help. Thanks.

Link to post
Share on other sites

Hello goatwriter,

Stop words feature considers each word separately and does not support quotation marks.

However it is still possible to make the analysis you want.

First, please go to Project Properties>General>Stop Words and remove "you" from the list.

Then make a text search query with below criteria:

"you know" ~1

Save the results a a node. (Let's name it "You know")

Then make a compound query with below criteria:

Compound Criteria>Subquery 1 >Text search

Criteria>

Search for: know

Finding matches: Exact

Search in: Text

In-between criteria: AND NOT

Compound Criteria>Subquery 2>coding Query

Criteria>

Simple>A Particular Code or Case: Select "You know"

Query Options>

Option: Create Results as A new Code or Case

Location: Nodes

Name: Know

Spread to: None

The query will provide you all the instances of know as a node, except places where "you know" is used. You can perform your desired analysis with the content of node "Know".

Hope this helps,

Regards,

 

 

Link to post
Share on other sites

Thanks for your response! In the compound query, should I have "AND NOT" selected instead of the default "NEAR Content"? I tried this and got a result, but I'm not sure how to use it.

With it not being a stop word, I can't block "you know" from a standard Word Frequency query. Or is there another way? I guess I could manually edit all the "you know"s to be "youknow", then they would show up as distinct from the other "know"s. Bit messy though.

Link to post
Share on other sites

Hello goatwriter,

 

Indeed I forgot to put in-between criteria. Updated original post.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...